[EU] Login Error

Incident Report for Mesh

Resolved

Our development pushed a hotfix to production and login is now functioning as intended.
Posted Jul 29, 2026 - 13:00 UTC

Investigating

Some partners have reported an error when attempting to login.

Our development team is investigating and we will provide an update as soon as possible.
Posted Jul 29, 2026 - 10:05 UTC
This incident affected: EU (MSP Hub).