EU - Error when attempting to release subset of emails
Incident Report for Mesh
Resolved
The issue has been resolved. All components are fully operational.
Posted Feb 27, 2024 - 12:41 UTC
Identified
A number of emails are producing an error when attempting to release from the Live Email Tracker and Quarantine Digest. Our engineers have identified the root cause and are working on a fix.

Thank you for your patience.
Posted Feb 27, 2024 - 12:00 UTC
This incident affected: EU (MSP Hub).