Emails slow to process on US service
Incident Report for Mesh
Resolved
The issue is resolved. All components are fully operational.
Posted Feb 26, 2024 - 13:45 UTC
Monitoring
A fix has been deployed and we're currently monitoring. Message processing times have stabilised.
Posted Feb 26, 2024 - 13:22 UTC
Identified
There are queues for inbound email on our US service. Our engineers have identified the issue and are working on implementing a fix.
Posted Feb 26, 2024 - 12:21 UTC
This incident affected: US (Inbound Email Security).