Slow performance of portal - EU service

Incident Report for Mesh

Resolved

The team have made some changes to mitigate the performance issues experienced with the LET
Posted Mar 26, 2025 - 19:18 UTC

Investigating

We are investigating the slow performance of the portal on our EU service. Email processing is not impacted.
Posted Mar 26, 2025 - 15:42 UTC
This incident affected: EU (MSP Hub).