Microsoft issue: emails from hotmail.com addresses failing SPF
Incident Report for Mesh
Resolved
It looks like Microsoft have now corrected this issue.
Posted Aug 18, 2023 - 17:04 UTC
Investigating
We have received reports that some emails from hotmail.com addresses are being rejected for SPF fails.

Upon investigation, these are correct rejects as they are coming from IP ranges not included in the SPF record for hotmail.com.

This looks like a configuration issue by Microsoft and is not exclusive to Mesh.
Posted Aug 18, 2023 - 08:51 UTC
This incident affected: US (Inbound Email Security) and EU (Inbound Email Security).