Slow Delivery Inbound to Office 365

Incident Report for Mesh

Resolved

We're no longer observing live deferred events. We're continuing to monitor the situation.
Posted Sep 04, 2026 - 15:12 UTC

Monitoring

We're beginning to see improvements with delivery into Microsoft 365's infrastructure. We are still seeing some messages being given a deferral by them. They have acknowledged the issue publicly and that they are applying mitigations.

We'll continue to monitor and post updates.

https://x.com/MSFT365Status
Posted Sep 04, 2026 - 13:00 UTC

Identified

This appears to be related to an ongoing issue on Microsoft 365s infrastructure. It can be tracked via the below link.

https://admin.cloud.microsoft/?#/servicehealth/:/alerts/EX1467029
Posted Sep 04, 2026 - 11:12 UTC

Update

Outbound Relay also appears to be affected. Only for traffic going to Office 365
Posted Sep 04, 2026 - 10:37 UTC

Investigating

We're seeing slower delivery into O365 for Mesh customers. We're currently investigating.
Posted Sep 04, 2026 - 10:09 UTC
This incident affected: EU (Inbound Email Security, Outbound Email Security).