Emails slow to process - US

Incident Report for Mesh

Resolved

Queues have cleared and email processing has returned to normal.
Posted Jul 15, 2025 - 15:32 UTC

Identified

Our engineers have identified queues for inbound email on our US service. We are working on a fix.
Posted Jul 15, 2025 - 14:44 UTC
This incident affected: US (Inbound Email Security).