Emails slow to process - US

Incident Report for Mesh

Resolved

Although Microsoft are still reporting issues here (https://azure.status.microsoft/en-us/status), our systems have been working as normal for the past few hours. We will continue to monitor.
Posted Oct 29, 2025 - 22:48 UTC

Identified

The team has linked these delays to an ongoing Azure issue. Details from Microsoft are limited at this time but we are monitoring the situation and continuing to investigate.
Posted Oct 29, 2025 - 16:42 UTC

Investigating

We have observed some slow DNS lookups on our US infrastructure.

This is causing some email delivery queues. The team is investigating and we will provide an update as soon as possible.
Posted Oct 29, 2025 - 15:15 UTC
This incident affected: US (Inbound Email Security, Outbound Email Security, MSP Hub).