Email Delays Inbound - EU

Incident Report for Mesh

Resolved

Queue times have returned to normal. We're continuing to monitor.
Posted Mar 25, 2026 - 11:56 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 25, 2026 - 10:34 UTC

Identified

We have identified the issue and a fix has been implemented.
Posted Mar 25, 2026 - 09:03 UTC

Investigating

We are currently investigating this issue.
Posted Mar 25, 2026 - 08:48 UTC
This incident affected: EU (Inbound Email Security).