Email Processing Delays - US

Incident Report for Mesh

Resolved

We are marking this incident as resolved but will continue to monitor closely.
Posted Feb 13, 2026 - 15:54 UTC

Monitoring

Queues have returned to normal and we are monitoring system stability.
Posted Feb 13, 2026 - 15:00 UTC

Investigating

Our infrastructure team has identified some email processing delays on our US service.
Posted Feb 13, 2026 - 14:19 UTC
This incident affected: US (Inbound Email Security).