US Mesh Gateway: Emails slow to process on US service
Incident Report for Mesh
Resolved
The issue has now been resolved.

Email queues have cleared, and new emails are being processed as normal.

Thank you for your patience!
Posted Oct 05, 2023 - 14:58 UTC
Identified
Our team has alerted Microsoft to the internal Azure issue and we are awaiting their response. We are investigating potential workarounds and will keep you up-to-date.
Posted Oct 05, 2023 - 14:32 UTC
Update
We are continuing to investigate this issue.
Posted Oct 05, 2023 - 13:54 UTC
Investigating
Correction to previous notification:
We are experiencing some slight delays to inbound email on our US service. We believe this is being caused by an Azure networking issue and are currently investigating further.
Posted Oct 05, 2023 - 13:49 UTC
This incident affected: US (Inbound Email Security, Outbound Email Security, MSP Hub).