Exchange Online is currently experiencing an incident that is delaying the delivery of email
Incident Report for Mesh
Resolved
Microsoft have resolved the issue and are continuing to monitor their changes.

Start time: Monday, October 9, 2023 at 10:00 PM GMT+
End time: Wednesday, October 11, 2023 at 6:00 PM GMT+1

Most users would have experienced up to a 1-hour delay; however, in some cases, users may have encountered delays of up to 24 hours.
The issue affected users worldwide and only for a portion of IP addresses, therefore not all users experienced impact.
Posted Oct 12, 2023 - 08:17 UTC
Identified
Microsoft are currently experiencing an issue that is impacting delivery of email to customers using Exchange Online. Microsoft have posted about this incident on their service health dashboard.

https://portal.office.com/Adminportal/Home#/servicehealth/:/alerts/EX680695

Affected users may see a "451 4.7.500 Server busy" error message."

Emails are being deferred/queued and we will continue to retry delivery.
Posted Oct 11, 2023 - 11:43 UTC
This incident affected: US (Inbound Email Security, Outbound Email Security, MSP Hub) and EU (Inbound Email Security, Outbound Email Security, MSP Hub).