US service: Emails slow to process
Incident Report for Mesh
Resolved
While Azure is still continuing to report an issue, this is not impacting our service. We're updating our incident status to resolved but will continue to monitor.
Posted Jun 20, 2024 - 18:38 UTC
Monitoring
Email is now flowing as expected.

Our team identified that the delay was caused by an ongoing Azure issue which impacted one of our filtering components. Our server redundancy handled the increased load. We're continuing to monitor processing times in case further action is needed.
Posted Jun 20, 2024 - 15:19 UTC
Investigating
The team is investigating some intermittent processing delays for inbound email on our US service.

We will provide a further update shortly.
Posted Jun 20, 2024 - 14:27 UTC
This incident affected: US (Inbound Email Security).