We can confirm successful delivery of emails to customers based in Australia on Microsoft 365. This has now been resolved and we will continue to monitor. Thank you.
Posted May 22, 2025 - 09:42 UTC
Update
All Mesh services are continuing to function normally, however, we are still seeing mail flow irregularities to Australian customers on Microsoft 365. This is not an issue specific to customers using Mesh.
We believe the issue is localised to Microsoft O365s AUS Infrastructure, as all other inbound traffic on the Mesh Gateway Service is unaffected. We'll continue to monitor.
Posted May 22, 2025 - 06:38 UTC
Monitoring
We're currently monitoring inbound delivery on the EU. Delivery times are currently within a normal range.
Posted May 22, 2025 - 05:27 UTC
Investigating
There appears to be some Email Delays on the EU Inbound Gateway Infrastructure. We're currently investigating.
Posted May 22, 2025 - 05:11 UTC
This incident affected: EU (Inbound Email Security).