Slow Mail Processing - US

Incident Report for Mesh

Resolved

Mail processing queues have returned to normal. We're continuing to monitor our infrastructure. For now everything is operational. There is a maintenance window in Azure this evening which we believe will resolve the the underlying throughput issue within their Networks.
Posted Oct 31, 2025 - 17:39 UTC

Monitoring

We're observing slow mail processing on the US infrastructure.
Posted Oct 31, 2025 - 13:38 UTC
This incident affected: US (Inbound Email Security).