Emails slow to process - US
Incident Report for Mesh
Resolved
All services are now fully operational. Queue levels have returned to a normal level. We don't anticipate a reoccurrence but will continue to monitor closely.
Posted Dec 13, 2024 - 18:11 UTC
Monitoring
Queues have continued to decrease steadily and we are monitoring closely.
Posted Dec 13, 2024 - 17:51 UTC
Identified
The team has identified a large spike in email traffic on our US infrastructure. Email delivery may be delayed but queues are clearing steadily.
Posted Dec 13, 2024 - 16:58 UTC
This incident affected: US (Inbound Email Security).