Email Processing Delays - US

Incident Report for Mesh

Resolved

This incident has been resolved.
Posted Feb 12, 2026 - 22:02 UTC

Monitoring

Mail Processing times have returned to normal. We're continuing to monitor.
Posted Feb 12, 2026 - 21:36 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 12, 2026 - 21:25 UTC

Investigating

We are currently investigating delayed message processing on the API service
Posted Feb 12, 2026 - 21:08 UTC
This incident affected: US (Inbound Email Security).