Emails slow to process on EU service
Incident Report for Mesh
Resolved
We can confirm that all mail queues have now cleared. We appreciate your patience while we worked to resolve this issue.
Posted Feb 21, 2024 - 11:33 UTC
Monitoring
A fix has been implemented and queues are starting to clear. We will post another update here shortly.
Posted Feb 21, 2024 - 11:04 UTC
Update
We are continuing our mitigation efforts for this issue. We are working on full resolution and will update this page as soon as we have further information.
Posted Feb 21, 2024 - 10:55 UTC
Identified
Our engineers have identified the issue and are working on implementing a fix.
Posted Feb 21, 2024 - 10:29 UTC
Investigating
There are queues to email on our EU service, both inbound and outbound. We are investigating.
Posted Feb 21, 2024 - 10:08 UTC
This incident affected: EU (Inbound Email Security, Outbound Email Security, MSP Hub).