[EU Outbound] Slow Email Delivery

Incident Report for Mesh

Resolved

Queues have cleared and latency has returned to normal. Thank you for your patience.
Posted May 27, 2026 - 10:21 UTC

Investigating

We have identified email delays on our outbound EU infrastructure. Inbound delivery is not impacted. We will provide a status update as soon as possible.
Posted May 27, 2026 - 09:42 UTC
This incident affected: EU (Outbound Email Security).