[US Infrastructure] Emails slow to process

Incident Report for Mesh

Resolved

Email processing times have returned to normal and queues have cleared. Thank you for your patience.
Posted May 26, 2026 - 15:59 UTC

Identified

We have identified minor email delays on our US infrastructure. We will provide a status update as soon as possible.
Posted May 26, 2026 - 15:01 UTC
This incident affected: US (Inbound Email Security).