Email Delays Outbound - EU

Incident Report for Mesh

Resolved

All services are operational.
Posted Mar 25, 2024 - 16:27 UTC

Identified

The issue has been identified and a fix is being prepared.
Posted Mar 25, 2024 - 15:45 UTC

Investigating

We are currently investigating email queues on the Outbound EU Infrastructure
Posted Mar 25, 2024 - 15:28 UTC
This incident affected: EU (Outbound Email Security).