[EU] Email Processing Delays

Incident Report for Mesh

Resolved

The issue has been resolved and email delivery has returned to normal.
Posted Mar 13, 2026 - 10:47 UTC

Identified

The team has identified an issue causing some inbound email delivery delays. A fix is being deployed shortly.
Posted Mar 13, 2026 - 10:07 UTC
This incident affected: EU (Inbound Email Security, Outbound Email Security, MSP Hub).