EU Service: Emails slow to process

Incident Report for Mesh

Resolved

Email traffic has returned to normal and all queues have cleared.
Posted Apr 23, 2025 - 12:20 UTC

Identified

The team has identified a spike in email traffic on our EU infrastructure. Email delivery may be delayed by a short period but systems are auto scaling and queues are clearing steadily
Posted Apr 23, 2025 - 12:07 UTC
This incident affected: EU (Inbound Email Security).