Mail Delays Inbound EU

Incident Report for Mesh

Resolved

All systems are operational.
Posted May 23, 2025 - 07:06 UTC

Update

We are continuing to monitor for any further issues.
Posted May 23, 2025 - 06:22 UTC

Monitoring

A fix has been implemented and we're currently monitoring.
Posted May 23, 2025 - 04:19 UTC

Identified

HUB access has been restored. Mails should begin flowing shortly.
Posted May 23, 2025 - 04:12 UTC

Investigating

We are currently investigating an issue with inbound mail flow in the EU.
Posted May 23, 2025 - 03:59 UTC
This incident affected: EU (Inbound Email Security, MSP Hub).