Emails queueing on EU service

Incident Report for Mesh

Resolved

Thank you for your patience while we worked on a fix. This incident is now resolved.
Posted Aug 02, 2023 - 02:09 UTC

Update

A fix has been implemented and all queues have cleared. We will continue to monitor.
Posted Aug 02, 2023 - 01:55 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 02, 2023 - 01:43 UTC

Investigating

We are currently investigating this issue.
Posted Aug 02, 2023 - 00:56 UTC
This incident affected: EU (Inbound Email Security, Outbound Email Security).