Emails slow to process on Mesh 365 (US only)

Incident Report for Mesh

Resolved

The issue has been addressed and mails are processing as normal on Mesh 365. We will continue to monitor. Thank you for your patience while we worked on this.
Posted Jan 28, 2026 - 00:36 UTC

Investigating

We are currently investigating an issue where emails are slow to process on Mesh 365 on our US service. Mesh Gateway and Mesh Unified is not impacted.
Posted Jan 27, 2026 - 23:12 UTC
This incident affected: US (Inbound Email Security).