[US Infrastructure] Slow Email Delivery

Incident Report for Mesh

Resolved

Email queues have cleared and latency has returned to normal. Thank you for your patience.
Posted May 29, 2026 - 15:46 UTC

Identified

We are aware of some inbound emails delivery delays on our US infrastructure. Our team is investigating.
Posted May 29, 2026 - 15:01 UTC
This incident affected: US (Inbound Email Security).