Mail Processing Delay - US Gateway Service

Incident Report for Mesh

Resolved

The small queue of emails has now cleared. All emails are processing as normal. Thank you for your patience while we worked on this issue.
Posted Feb 18, 2025 - 16:05 UTC

Identified

The issue has been identified and impacts a small subset of email which is still in a queue. We are working to resolve this issue. New email is being processed as normal.
Posted Feb 18, 2025 - 15:17 UTC

Investigating

We are currently investigating this issue.
Posted Feb 18, 2025 - 14:32 UTC
This incident affected: US (Inbound Email Security).