Slow Portal Performance & Email Delivery [EU]

Incident Report for Mesh

Resolved

Changes have remained stable and email latency is normal. Thank you for your patience.
Posted Jul 24, 2026 - 11:03 UTC

Monitoring

We have implemented a fix and are currently monitoring performance. Email is now flowing, however, emails received during the performance degradation window may have received a 450 rejection message.

This 450 code informs senders to temporarily back off and retry delivery at a later time. As a result, there may be delay receiving certain emails. Please note that the time frame for a retry is decided by the sender's infrastructure and is not controlled by Mesh.
Posted Jul 24, 2026 - 09:58 UTC

Update

We have identified performance issues on our mail servers which is impacting email delivery. The team is investigating the root cause and we will provide an update as soon as possible.
Posted Jul 24, 2026 - 09:29 UTC

Investigating

We are investigating slow performance of the portal on our EU service. Email processing is not impacted.
Posted Jul 24, 2026 - 09:19 UTC
This incident affected: EU (Inbound Email Security, MSP Hub).