Emails slow to process on EU service

Incident Report for Mesh

Resolved

This incident has been resolved.
Posted Mar 31, 2023 - 16:02 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 31, 2023 - 13:11 UTC

Update

We believe this was caused by an Azure networking issue which caused emails to queue.


All queues have cleared and email is now processing as normal.


We are continuing to monitor and have prepared to failover in the even of a reoccurrence
Posted Mar 31, 2023 - 13:10 UTC

Investigating

We are currently investigating this issue.
Posted Mar 31, 2023 - 12:09 UTC
This incident affected: EU (Inbound Email Security, Outbound Email Security).