Emails slow to process - US

Incident Report for Mesh

Resolved

Mail processing queues have returned to normal. We're continuing to monitor our infrastructure. For now everything is operational.
Posted Oct 30, 2025 - 17:01 UTC

Monitoring

We're observing a recurrence of the issue on Azure whereby emails are slow to process on the US infrastructure. We're currently monitoring the situation and have reached out to Microsoft for a status update.
Posted Oct 30, 2025 - 13:34 UTC
This incident affected: US (Inbound Email Security).