Slow Email Delivery - Inbound US

Incident Report for Mesh

Resolved

Inbound queues have cleared and delivery times have returned to normal. Thank you for your patience.
Posted Apr 23, 2026 - 16:57 UTC

Monitoring

Queue volume is dropping steadily and the infrastructure team is monitoring performance.
Posted Apr 23, 2026 - 16:18 UTC

Investigating

We are currently investigating some inbound delivery queues on our US infrastructure. We will provide an update as soon as possible.
Posted Apr 23, 2026 - 15:44 UTC
This incident affected: US (Inbound Email Security).