Emails slow to process on EU service
Incident Report for Mesh
Resolved
This incident is now resolved. Thank you for your patience while we worked on a fix.
Posted Mar 28, 2023 - 12:03 UTC
Update
The issue is now fixed and queues have cleared. Email is processing as normal. We will continue to monitor.
Posted Mar 28, 2023 - 11:30 UTC
Identified
We are experiencing some delays to inbound email on our EU service. The issue has already been identified. We will provide a further update shortly.
Posted Mar 28, 2023 - 11:17 UTC
This incident affected: EU (Inbound Email Security).