Inbound delivery issue on US service
Incident Report for Mesh
Resolved
All queues have now cleared. We will continue to monitor. Thank you for your patience.
Posted Oct 23, 2024 - 20:30 UTC
Monitoring
A fix has now been implemented. Microsoft has stopped rate limiting our delivery ranges. It will take a little bit of time for the queues to clear. We will post another update shortly.
Posted Oct 23, 2024 - 19:04 UTC
Update
While our team are continuing to rotate our delivery ranges to ensure the maximum volume of email can be delivered, Microsoft continue to rate limit email delivery from our ranges. We are continuing to work with their support teams to fix this. Thank you again for your patience.
Posted Oct 23, 2024 - 18:26 UTC
Update
We have deployed our failover delivery range which has seen an improvement, but Microsoft are still rate limiting delivery. We are continuing to work with them to fix the issue.
Posted Oct 23, 2024 - 17:15 UTC
Update
Our engineering team have added additional delivery ranges to mitigate the issue. Some emails are being delivered while others are being deferred. Any deferred emails will be delivered once a fix has been implemented. We are working with Microsoft on this. We will provide a further update in due course. Thank you for your patience.
Posted Oct 23, 2024 - 16:27 UTC
Identified
We have identified the issue. Microsoft is rate limiting our delivery of emails inbound on our US infrastructure. Our engineers are working on a fix. Any deferred emails will be delivered once the issue is fixed.
Posted Oct 23, 2024 - 15:28 UTC
Investigating
We are investigating reports of emails being deferred inbound on our US service
Posted Oct 23, 2024 - 14:42 UTC
This incident affected: US (Inbound Email Security).