Slow Email Delivery - Inbound EU

Incident Report for Mesh

Resolved

Message processing has returned to normal and all queues have cleared.
Posted Mar 23, 2026 - 11:49 UTC

Monitoring

We're currently monitoring the changes. The queue is continuing to drop. We will post another update once cleared.
Posted Mar 23, 2026 - 11:23 UTC

Identified

The issue has been identified and we're implementing a fix.
Posted Mar 23, 2026 - 11:12 UTC

Investigating

We are currently investigating Delivery Queues on our EU infrastructure.
Posted Mar 23, 2026 - 10:55 UTC
This incident affected: EU (Inbound Email Security).