[US Infrastructure] Slow Email Delivery

Incident Report for Mesh

Resolved

Email queues have cleared and latency has returned to normal. Thank you for your patience.
Posted May 28, 2026 - 18:27 UTC

Identified

We are aware of some inbound emails delivery delays on our US infrastructure. Our team is investigating and we will provide an update as soon as possible.
Posted May 28, 2026 - 16:05 UTC
This incident affected: US (Inbound Email Security).