EU Service: Emails slow to process

Incident Report for Mesh

Resolved

Mailflow has returned to normal. Thank you for your patience!
Posted Nov 10, 2023 - 12:55 UTC

Investigating

We are experiencing some delays to inbound email on our EU service. We are investigating the situation and will provide a further update shortly.
Posted Nov 10, 2023 - 12:27 UTC
This incident affected: EU (Inbound Email Security).