Emails slow to process - EU

Incident Report for Mesh

Resolved

Queue times have returned to normal. Thank you for your patience.
Posted May 21, 2026 - 10:22 UTC

Identified

We are currently investigating short email delays. We will post an update as soon as possible.
Posted May 21, 2026 - 09:32 UTC
This incident affected: EU (Inbound Email Security).