Slow Email Delivery - Inbound EU

Incident Report for Mesh

Resolved

Message processing has returned to normal and all queues have cleared. We will continue to monitor.
Posted Mar 24, 2026 - 11:26 UTC

Identified

The team has identified the root cause and is working on a fix.
Posted Mar 24, 2026 - 10:30 UTC

Investigating

We are currently investigating some inbound delivery queues on our EU infrastructure.
Posted Mar 24, 2026 - 09:47 UTC
This incident affected: EU (Inbound Email Security).