Emails slow to process on EU service
Incident Report for Mesh
Resolved
This incident has been resolved.
Posted Apr 04, 2023 - 13:23 UTC
Monitoring
These queues have now cleared and we are monitoring.
Posted Apr 04, 2023 - 11:22 UTC
Identified
Some customers may notice a small delay on inbound email processing (approximately 10 minutes). The issue has already been identified and a fix is being put in place.
Posted Apr 04, 2023 - 11:08 UTC
This incident affected: EU (Inbound Email Security).