Slow Message Delivery to Microsoft Services

Incident Report for Mesh

Resolved

Microsoft are reporting the issue as largely resolved. Queues have returned to normal Outbound services but we're still processing a significant backlog Inbound on our US infrastructure. We will continue to monitor.
Posted Jan 23, 2026 - 06:18 UTC

Update

We're continuing to monitor the issue and will keep you abreast of any official developments. We recommend for our impacted customers to also follow.

https://status.cloud.microsoft/m365/
Posted Jan 22, 2026 - 20:17 UTC

Monitoring

We're currently monitoring a situation affecting message delivery to Microsoft Services.

https://x.com/MSFT365Status/status/2014422298506285161
Posted Jan 22, 2026 - 20:10 UTC
This incident affected: US (Inbound Email Security, Outbound Email Security) and EU (Inbound Email Security, Outbound Email Security).