US Service: Emails slow to process

Incident Report for Mesh

Resolved

This incident has been resolved and the queues have cleared.
Posted Oct 13, 2023 - 21:30 UTC

Investigating

Emails are currently slow to process on our US service. We believe this is a recurrence of a networking issue in Microsoft seen last week.

Our engineers are currently investigating.
Posted Oct 13, 2023 - 21:08 UTC
This incident affected: US (Inbound Email Security, Outbound Email Security).