Outbound Emails Quarantined Due to Heuristic Filter
Incident Report for Mesh
Resolved
The changes made at 11:25 UTC have remained stable and there have been no further emails impacted since this time.

Thank you for your patience!
Posted Nov 08, 2023 - 12:32 UTC
Monitoring
At 11am UTC an issue occurred with a heuristic filter on our outbound smarthost service that caused some emails to be quarantined.

The issue was remediated and fully resolved at 11:25 UTC. We are monitoring the changes made.

Outbound quarantine alert notifications will have been generated during this time.

Emails can be released in bulk via the Live Email Tracker. Multiple emails can be selected at once using the checkboxes in the left most column.

More information can be found here:
https://docs.emailsecurity.app/help-center/delivering-deleting-an-email
Posted Nov 08, 2023 - 11:45 UTC
This incident affected: US (Outbound Email Security) and EU (Outbound Email Security).