Slow Message Delivery to Microsoft Services

Incident Report for Mesh

Resolved

Mail delivery is functioning as expected. We're continuing to monitor the situation. We're closing out this status.
Posted Jan 23, 2026 - 14:36 UTC

Update

We expect all messages to be delivered in ~30 mins. New emails are being delivered as normal.
Posted Jan 23, 2026 - 07:51 UTC

Monitoring

Spoke too soon. Apologies for the miscommunication. Outbound processing queues have returned to normal. There is still a heavy queue Inbound on the US infrastructure with delivery into 365 static. Microsoft are reporting that all services are operational we will continue to monitor ...
Posted Jan 23, 2026 - 06:31 UTC
This incident affected: US (Inbound Email Security).