Our team has received further feedback from Spamhaus earlier this morning. The listings were caused by an end user emailing a spamtrap/honeypot operated by Spamhaus.
The honeypot domain is a typosquat of a well known brand and the emails sent were not malicious traffic.
We have reached out to the MSP so they can advise their end user of the mistake/typo.
Posted Aug 28, 2025 - 08:54 UTC
Identified
We are aware that one of our outbound IP addresses was listed on Spamhaus' RBL.
This IP has been removed from our sending relays and the team is actively working with Spamhaus to identify a root cause.
At this time, we do not anticipate any ongoing impact to email delivery and we are closely monitoring for further reports. No action is required from end customers or partners.
Posted Aug 27, 2025 - 13:40 UTC
This incident affected: US (Outbound Email Security) and EU (Outbound Email Security).