Mails slow to process - uS

Incident Report for Mesh

Resolved

Queues have cleared and processing times have returned to normal.
Posted Jun 28, 2024 - 19:55 UTC

Identified

The team has identified the issue and queues are clearing. Some mail flow is delayed.
Posted Jun 28, 2024 - 19:45 UTC
This incident affected: US (Inbound Email Security).