Outbound IP Range - SpamHaus
Incident Report for Mesh
Resolved
Outbound traffic has returned to normal and Spamhaus has delisted impacted IPs. Any bounced messages will need to be resent.

We will continue to investigate internally.

Thank you for your patience.
Posted Dec 11, 2023 - 15:53 UTC
Investigating
We are investigating reports of outbound emails being rejected/bounced by Spamhaus.

At present, it appears that this is an issue with Spamhaus in general and is also affecting non Mesh customers.

We have removed known listed IPs from our outbound delivery range to help alleviate delivery issues.

Further updates will be provided shortly.
Posted Dec 11, 2023 - 15:00 UTC
This incident affected: US (Outbound Email Security) and EU (Outbound Email Security).